Módulo Cartão de Crédito Offline com parcelamento v3.0 para PS v1.4.8

Postado em Atualizado em

Como o mesmo módulo anterior, este módulo é também uma fusão de dois módulos já existentes, contudo, com várias e profundas modificaçôes, a fim de que ambos trabalhassem como um só.

O módulo capta as infomações do cartão de crédito do cliente e, opcionalmente, a opção de parcelamento.

No entanto, o processamento da validação do cartão junto ás operadoras é realizado manualmente. O módulo, como já dito, apenas capta estas informações.

Após concluído o pedido, estas informações podem ser consultadas na aba Pedidos> no Back Office.

Demanda algumas melhorias visuais, mas nada que um bom web designer não possa aprimorar nos arquivos tpl.

Instalação: Padrão do PrestaShop.
Descarga:CreditCard Offline v3.0.
Testado na versão: PS v1.4.8.

Informações adicionais: Este módulo é donationware, se lhe foi útil, considere fazer uma doação.


Pague com PagSeguro - é rápido, grátis e seguro!

45 comentários em “Módulo Cartão de Crédito Offline com parcelamento v3.0 para PS v1.4.8

    Rafael Trigoel disse:
    agosto 29, 2012 às 8:56 am

    Estou com esse erro.
    Vo que forum do presta alguém conseguiu arrumar inserindo alguma tabela, mas não sei qual ou onde. Podes me ajudar?

    Fatal error (OrderHistory -> id_order_state is empty)

    Yago Pádua disse:
    novembro 1, 2012 às 10:42 am

    Alguma versão adaptada pra 1.5.2 ou alguma forma de adaptar? Testei ela na versão, porém quando o cliente chega na parte de selecionar a forma de pagamento, a página fica em branco…

      ehinarr respondido:
      novembro 22, 2012 às 11:40 pm

      Ainda não, mas está nos planos, todos os módulos gratuitos serão atualizados paulatinamente. Experimentou mudar a versão do smarty?

    Regiane Fernandes disse:
    dezembro 1, 2012 às 1:56 pm

    Olá,estou interessada em pagar para esse modulo ser desenvolvido para a versao 1.5.2 e como confio no seu trabalho gostaria de saber se tem interesse em firmar essa parceria.
    por gentileza entre em contato
    aguardando

      ehinarr respondido:
      dezembro 1, 2012 às 7:31 pm

      O módulo ainda não foi testado nas PS v1.5, mas devo fazer isso nos próximos dias.

        Yago Pádua disse:
        fevereiro 20, 2013 às 10:18 am

        E aí Ehinarr? Alguma novidade pra atualização do módulo pra 1.5? Abração!

          ehinarr respondido:
          fevereiro 20, 2013 às 4:16 pm

          Ainda não, está difícil atualizar os módulos de forma eficiente, a sistemática mudou.

    Luis Frauendorf disse:
    março 14, 2013 às 6:45 am

    Ehinarr, tudo bem? Preciso muito desse módulo. Você conseguiu a atualização dele? Abs

      ehinarr respondido:
      março 23, 2013 às 1:52 pm

      Para v1.5.3? Acho que sim, testei rapidamente e parece estar tudo bem, devo disponibilizar estes dias.

    Yago Pádua disse:
    maio 15, 2013 às 3:03 pm

    Já foi disponibilizado?!

      ehinarr respondido:
      maio 22, 2013 às 6:52 pm

      O link do forum está off, se não voltar, terei que achar outro lugar para colocar os arquivos para descarga…

    Reginaldo disse:
    junho 10, 2013 às 2:43 pm

    Olá Ehinarr, tudo bem? Estou precisando muito deste módulo, tem como disponibilizar para a versão 1.5.3.1? Estou disposto a pagar por ele, pois sera muito util para minha loja.
    Abraços

    vitor disse:
    junho 25, 2013 às 11:02 am

    Preciso do modulo alguma noticia?

        Yago Pádua disse:
        junho 25, 2013 às 6:00 pm

        Versão 1.5 esse?

          ehinarr respondido:
          junho 25, 2013 às 7:03 pm

          É para ser…

            Vítor Martins disse:
            junho 27, 2013 às 9:58 am

            Estou tendo o problema que fica em branco o caminho não prossegue http://localhost/papel/index.php?controller=order&multi-shipping=

            Reginaldo disse:
            junho 27, 2013 às 6:15 pm

            Testei na versão 1.5.3.1 e ocorreu o erro abaixo logo após selecionar o frete e clicar no botão próximo para exibir as formas de pagamento.

            Erro HTTP {500 (Internal Server Error): Ocorreu uma condição inesperada enquanto o servidor tentava completar a solicitação.

              ehinarr respondido:
              junho 27, 2013 às 6:59 pm

              Erro 500 geralmente é erro de programação, vou dar uma olhada nisso.

                Reginaldo disse:
                julho 2, 2013 às 5:29 pm

                Valeu Ehinarr, assim que fizer a alteração me avise que faço mais testes. Eu tentei acertar o problema mas o código esta criptografado.
                Muito Abrigado

                  ehinarr respondido:
                  julho 5, 2013 às 12:48 pm

                  O problema está na composição da select da data no smarty, mais precisamente o formato da data do dia, por acaso você usou smarty 2 ao inés de 3?

                    Reginaldo disse:
                    julho 15, 2013 às 11:23 am

                    É o Smarty 3, fiz diversos testes, inclusive reinstalei o Smart mas não funcionou. Ahei outro módulo na interner que funcionou, mas não tem opção de parcelamento. Abraços.

    Vitor disse:
    julho 3, 2013 às 5:51 pm

    Alguma noticia? Para o 1.5.3

      ehinarr respondido:
      julho 5, 2013 às 12:47 pm

      Tem o link para esta versão aqui mesmo nas mensagens…

    Ivo disse:
    julho 15, 2013 às 7:02 pm

    Olá Ehinnar. Uso o PS 1.5.4.1 e deu problema no arquivo sysplugins/smarty_internal_template.php na linha 634 : throw new SmartyException(‘Missing template name’);

    Saberia dizer como corrigir este erro?

    Obrigado

      ehinarr respondido:
      julho 23, 2013 às 9:12 am

      Muda a versão do smarty, deve ser isso.

        Ivo disse:
        agosto 3, 2013 às 10:02 am

        O Smarty utilizado é recente versão 3.1.13 e ainda assim continua o erro.

          ehinarr respondido:
          agosto 6, 2013 às 6:45 pm

          É para 1.5 que você quer não é? Já estou findando as devidas correções, amanhã devo atualizar o módulo para descarga.

            Vítor disse:
            agosto 9, 2013 às 1:45 pm

            Deu certo de atualizar o modulo?

              ehinarr respondido:
              agosto 9, 2013 às 3:58 pm

              Sim, me parece que está bem agora. Vou atualizar no Google docs esta noite. Tem um Post no blog só pare a versão 1.5, então acompanhe por lá.

              ehinarr respondido:
              agosto 9, 2013 às 8:42 pm
                Ivo disse:
                agosto 11, 2013 às 11:15 am

                Agora sim está perfeito Ehinnar! Parabéns!!

                Só uma pergunta, como trata-se de um módulo de pagamento (que inclui dados de cartão de crédito etc) não teria como deixar o módulo sem codificação? Assim seria possível verificar se por acaso não há algum código malicioso por trás (de forma alguma estou duvidando da seriedade e honestidade do seu trabalho, mas tratando-se informações financeiras do cliente é vital ter toda segurança possível).

                Haveria também a possibilidade de adicionar uma opção de cobrar os juros somente a partir de X parcelas?

                Caso for lançar uma versão comercial nos avise, senão irei fazer uma doação através do PagSeguro em agradecimento.

    Rafael Trigo disse:
    agosto 24, 2013 às 11:08 am

    Bom dia!

    Estou recebendo a msg:

    Warning: Function addCSS() is deprecated in /home/blogdeurza/qgblumenau/public_html/loja/modules/creditcard/creditcardext.php on line 1
    in /home/blogdeurza/qgblumenau/public_html/loja/classes/Tools.php on line 1845

    Pesquisando vi que é porque essa função será extinta, mas como o código está encriptado não consigo arrumar. Pode me ajudar?

      ehinarr respondido:
      agosto 24, 2013 às 11:17 pm

      Isto acontece se vc usar a versão para 1.4 na 1.5, foi issow Já tem versão para 1.5 posta aqui mesmo, dá uma olhada.

    Jonas disse:
    agosto 29, 2013 às 5:34 pm

    Olá Ehinarr,

    Só uma questão. Após finalizar a compra tudo no sistema recebe o valor a vista pago, ou seja, o email enviado ao cliente, o histórico no site a confirmação do pedido…. tudo isso fica com o valor de a vista.
    Não teria como alterar isso para o valor final da compra já com os juros de parcelamento?

    Yago Pádua disse:
    outubro 22, 2013 às 3:14 pm

    Boa tarde Ehinarr,

    A última versão do módulo que você disponibilizou pra versão 1.5.x não funcionou no presta 1.5.2.0. Após digitar os dados do cartão e confirmar o pedido, a página fica em branco e o pedido não é finalizado.

    Pode me ajudar?

    Atenciosamente,

      ehinarr respondido:
      outubro 24, 2013 às 5:41 am

      Você usou a versão para 1.5?

        Yago Pádua disse:
        outubro 24, 2013 às 11:07 am

        Usei sim, é minha versão atual. =/

          ehinarr respondido:
          outubro 24, 2013 às 11:26 am

          Habilite a mostra de erros do prestashop, no arquivo config/defines.inc.php, e teste novamente, com sorte poderemos identificar o problema:

          /* Debug only */
          define('_PS_MODE_DEV_', true);

            Yago Pádua disse:
            outubro 24, 2013 às 2:19 pm

            Desculpe, creio que foi um erro meu, eu não havia adicionado nenhum cartão (Master, VISA e etc.) como pagamento. Adicionei e o módulo finalizou a compra corretamente.

            Gostaria de saber se há uma versão comercial que eu possa comprar, onde eu teria acesso ao código do módulo, descriptografado, por motivos apontados pelo nosso amigo Ivo nos comentários acima do meu.

            Obrigado mais uma vez pelo suporte e pelo trabalho.

            Atenciosamente,

    Valdeir Júnior disse:
    novembro 13, 2013 às 10:38 am

    Bom dia, primeiro parabéns pelo módulo, eis a dúvida:
    gostaria de saber se tem como o CVC nao aceitar menos de 3 numeros, pois quando coloca só 2 numeros o módulo aceita e na hora de passar o pagamento do cliente nao da certo. Obrigado.

    Renan disse:
    abril 21, 2015 às 3:12 pm

    Este modulo funciona na versão PrestaShop v1.6.0.14 ?

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s